CNAMEs not working on delegated domain

I’ve created a delegated single zone domain and corresponding zone with A, AAAA and MX and TXT records. These all seem to be working correctly. However I’ve tried adding CNAME records (for example but I can’t resolve them. Even using
fails to resolve the cname. I’ve now tried with two domains and I can’t get either to work with cnames.

I’ve tried ssh and can see the following:

> hosts records 
  NAME | TYPE  | PRIORITY |            VALUE              
  @    | MX    |       10 |                 
  @    | TXT   | -        | v=spf1 a mx ip4:  
  @    | CNAME | -        | www                           
  @    | AAAA  | -        | ::aaaa:bbbb:cccc:dddd     

(obviously I’ve obfuscated real domain name and ip addresses)

Does anyone have any suggestions? Thanks

CNAME records without names do not work. Instead you should create a CNAME record for www that points to @ (or empty string).


www CNAME @


@ CNAME www

Thanks, I’ve got it working now. I’d assumed that the @ went in the field that says, " Leave empty or use @", but that’s actually where I enter the cname. I have to enter ‘’ into the data field.

1 Like

The validations for CNAME records are more strict now. Empty names are not permitted any more.

It seems something broke,
because if I enter @ in the data field I get an error message : “must be a valid hostname”

Thank you for your help

Thanks for your feedback. Empty targets (not @) are now allowed and will be resolved the zone itself.