DNS zone not propagating

I’ve used dynv6.com for many months now, but it seems lately I’m having trouble with my DNS zone not getting propagated throughout the Internet. For example, I have a PowerShell script that runs every hour on my Windows PC. It checks the last IP it recorded and if it has changed, it invokes a Rest Method to update the IP in my zone at dynv6.com. This works, and the record gets updated properly. But if I look today for example, the record shows updated 3 days ago, yet when I query DNS on the Internet (Google DNS - or it does not show what is listed in my zone on dynv6.com. Any ideas?

i had the same problem (with the dns update), dont know the reason… But if you look in the nameserver of dynv6 (ns1.dynv6.com, ns2+ ns3) then they were sometimes different (mostly ns3. had the old ip). I made a script, wich checks directly after the update, if the update worked right. And have no problems right now.
The script: https://github.com/LRahlff/dynv6update

I’m facing the same problem now for the last few days.
All IP addresses are shown correct in the zones on dynv6 but as it was already written, the changes are not populated properly.

I’ve tried several DNS servers from Quad9, Level3, OpenDNS and others with always different results.
I currently update my zones using a python script that is triggered by a cron job every 5 minutes.

@randomserver42 I saw that you made a python script as well. So I will give this a try.
It’s strange that this problem for me came up just a few days back. I’m using dynv6 now for several years and never had any issues like that…

Yes i had always different results too, but when i checked the nameservers of dynv6, they had “consistent” data, they were different, but each server had (with multiple checks) the same data…

How do you update your records? Which protocoll of communication? I used a DNS update and there i had the Problem. Here is another solution (not sure if that worked always):
After your update you add another record to a nonused subdomain, and delete it directy.
The Problem appears (i read anywhere in a thread) only for the latest update…
(Another thread: AAAA records sporadisch falsch)
Same Problem: The ns[1-3].dynv6.com not always updated with my public IP address

I set no records on my subdomains. I only need the IP to be updated.
This is done in a Python script with a requests library get request to the dynv6 api

 endpoint =  f'https://dynv6.com/api/update?token={token}&ipv4={target_ip}&zone={d}'
    print(f'Full call Endpoint: {endpoint}')
    r = requests.get(endpoint)

in the DNSv6 Zone overview I than see, that the new IP addresses are set.
But when I ping the domains I get varying results. Some already show the new IP and some keep the old IP. It’s even not updated for several hours.