E-Mail changing bugs

I just encountered 2 Bugs when I tried to change my mail-adress:

  • It didn’t recognise my primary mail-address […]@[…].us.to
  • I was told to leave the password blank but I actually need to change my password to the same password to make it work

Thanks for the Service which seems so great (I sadly haven’t used it yet, but it looks awesome!)

Thanks for your bug report. I’ll take a look at it.

I’ve just rewritten the form to change the email address. There you go:

I think this might have introduced a bug. I missed a yearly mail for verifying the email address, and didn’t find a link to click to get a new verification mail. I tried changing the email address, which sent a new confirmation mail, and then gave the option to cancel the mail change.

I cancelled the mail change, and was able to log in with the original email, and not get the notification about verification not being done.

A day later, logging in with either the original or new email address both fails (error “Invalid Email or password”). Creating a new account with the new email works, creating a new account with the old email fails (“is invalid”). Password reset with the original email fails (“not found”). The original account seems to be stuck in zombie mode.