FTP: connection refused


I’m new here. Just started using this site and it’s looks promising.

My environment: RasPi with raspbian.
My goal: to access this machine from the outside world.
Problem: i am using Unitymedia (now Vodafone) which is IPv6-only.

I registered a subdomain here and made the needed entries. This is the status:

  • I can ping my url from outside (if the provider does not disable IPv6)
  • I can access my RasPi by ssh
  • I can access my RasPi by sftp
    Proble: I cannot access it via ftp. The console says:

august@August-Ryzen:~$ ftp augustq.dynv6.net
ftp: connect to address 2a02:908:1994:ce80:ba27:ebff:fe21:c296: Connection refused

What can I do in this case?

PS: I want to access my RasPi from my tablet running Android. I installed the TotalCommander which has a nice GUI and a FTP-Plugin. This always switches to IPv4-address. Same for the SFTP-plugin.

OK, problem solved.

I created an entry here, did NOT add the IP-adresses but created a record of type AAAA with the IPv6-address of my RasPi. This worked.