"has already been taken" - What to do?

Hello there,
I´m renting a domain from ionos and want to add it into my Profile here at dynv6.com so that I can use it for a private server project.
The problem is that it always shows the message “has already been taken” when I try to add it into my list of domains.

I have a few other domains rented from ionos and added which worked just fine. So is there a way to maybe “reset” this domain or delete it so that I as the real owner can use it?

I really want to stay here at dynv6.com because it´s normally very easy to set up and has worked for a couple of years for me now.

thanks for your advise in advance.

I am not sure how you are wanting to use the domain. I also have IONOS and I use dynv6 because it has an API I can script for DNS authentication with Let’s encrypt.
What I do is create CNAMEs in IONOS that point to my dynv6 records.
I don’t think you can delegate the zone to dynv6 from IONOS (I’m not sure I would want to either :smiley: ) You can redirect subdomains in a similar way I think.