AAAA record got lost


I have two zones here. Both zones have a few records and an additional records like this:
A router not set
AAAA router ::0:0:0:1

(the A inherits the IP from the zone)

Works pretty fine when I do zone updates.

However, after some time like 3-4 weeks or so, this record disappears magically. It’s not shown in the management console and does not resolve in DNS anymore and I’ve to manually create it new.
Observed this twice already.

Can you reproduce that behavior? Maybe there is a bug in you backup/restore mechanisms.

Thanks and kind regards,



we don’t have a “regular restore” mechanism to speak of. Once the data has entered the database, it should stay there until it is deleted manually.

There might be an issue with the way we do caching, where the first few lookups after a fresh software deployment or server restart is not yet cached properly - but that time window is relatively small, and it should auto-correct itself within a very short time.

Anyway, thanks for the report. We’ll investigate this further. Please let us know, if and when this happens again.


thanks for you reply!

I don’t think it’s related to caching. According to my router logs, the hostname couldn’t be resolved for at least four days.

Today it happened again, but even weirder: the AAAA and the CAA record for the @ hostname got lost.
If you want to look into my account, I’ve three zones. Just ignore the “test” one. It happened on both of the other two. I’ve restored one manually and the other one is untouched for you to investigate. But formerly contained the same records.


1 Like

It looks like there was an issue with our database cluster (one node was disconnected and stuck in a reboot cycle).

I’ve restarted the DB node. Please check if this fixes your problem.

Only updates written to and queries targeted at should have been affected.

thanks! But I cannot really confirm a fix. The missing records still do not show up in the web-frontend and none of the three is able to resolve them.

This happens for me, too. It takes a few seconds for a newly created AAAA record to disappear. Things broke for me this afternoon.

Same just happened for me.

Last week I found that the AAAA record wasn’t updating when I changed the IPv6 address in my zone, and today the AAAA record was completely missing. I updated the zone but the AAAA record wasn’t recreated.

I manually recreated the AAAA record, which worked for a while but it has disappeared again

I have the same problem!!!

Since yesterday the AAAA record ist lost after a very short time i.e. 1 Minute.
I do an update. I can see it on the record page and after a refresh one minute later it is gone.

1 Like

Same behaviour here…

I think the update is deleting the AAAA record. I have turned of my auto-updating (which is usually re-stating the same IPv6 address) and I haven’t lost my connectivity since.

It just means I need to keep an eye on when my ISP changes my address range and manually reset it (with a manual recreation of the AAAA record)

1 Like

Same problem with my AAAA record a few months ago and again last friday (10/23/20).
I manually added the AAAA record, but it didn’t work so I had to recreate the zone.

Today the AAAA was missing again, an update with the update-url recreated the AAAA record and it works.

I too have lost AAAA record entries. It happened once last week and again yesterday. Either manually entering the record or using the update API worked to re-set the record.

Couldn´t see any pattern or clues as to why it happened.

Same here. I loose AAAA-Records every couple of days. Any news on whether this will be fixed soon?

Same here. Yesterday, I fixed all manually then today again all are missing!

1 Like

I doubt there is some security issue with http tokens, where an attacker could simply clear all data.
I’ve all removed http token and records are not cleared after some minutes, I’m monitoring.

1 Like

I have three different zones. One of them is updated via ddclient only for IPv4. IPv6 I set there manually. The other two zones are used only with IPv6 and get updated manually. I’ve monitor the same behavior, that the AAAA records of all zones lost/deleted after few hours. Looks like all three get lost at the same time.
Cause of only manual updates I think there is no issue with http tokens. I think there is an other issue.
Maybe some cache problems.

Maybe this could help a bit: My zones are in alphabetical area “e”, “n” and “m”.

Any updates if this get solved soon?

Thank you in advance.

I had to recreate my zone a week ago, because it suddenly lost the AAAA record. Editing did not help, but delete and recreate worked.

Now, a week later, same issue. AAAA record gone, IPv6 prefix gone in the configuration, editing it back in doesn’t work.

nice to see that I’m not alone with this problem.

Unfortunately I see that my AAAA records, which I create manually few hours ago cause they get lost, are lost again.

I get the Message: “This zone does not have any records yet.”

Do somebody habe any idea why this happen?
I read for some people the records get lost after some weeks. For me now it happens after few hours.

The Mean Time between Failure (AAAA record lost) is in the range of 1 minute to some hours in my experience.
So, yes, dynv6 is completely unusable right now. As a workaround I manually enter the IPV6 Address in the AAAA record of my DNS provider and do hope for the best, that the VDSL connection remains stable and I do not get a new one after resync…