Web Server behind FritzBox

Dear Community, I think this topic has been discussed several times here. However I did not find a solution for me. I like to reach my Web Server behind my FritzBox. I followed the instructions to setup my Fritzbox and defined a zone with one AAAA record. In the AAAA record I set up the Host ID of my Web Server, resp. the MAC Address. The dynamic IPv6 prefix is updated correctly every time the FritzBox receives a new IP. Everything works fine until the next update of the prefix (by my DSL provider). The AAAA record is updated with the (new) IPv6 of the Fritzbox instead of the combination (old) Host ID (Web Server) with (new) dynamic IPv6 prefix. Again I end up on the welcome page of my FritzBox. What do I wrong? Any help is very much appreciated. Thanks in advance.

Use
https://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv6prefix=<ip6lanprefix>
as your update URL in the FritzBox (<ip6lanprefix> instead of <ip6addr>).

1 Like

Thank you so much. It works.

Well, it’s nearly correct. You should use 47906.dynv6.net (the full zone name) after “hostname=”.
Sorry I didn’t realize my code line above being mangled. The hostname is missing there for some reason.
But if you’re on a Fritzbox you better use
https://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv6prefix=<ip6lanprefix>
litterally as shown here. The keywords in angle brackets (<hostname> etc.) are replaced with the correct values by the Fritzbox automatically. Don’t remove the angle brackets.
BTW, I hope you didn’t publish your real token here. Otherwise consider to generate a new one.

For reference see
https://dynv6.com/docs/apis
and
https://service.avm.de/help/en/FRITZ-Box-Fon-WLAN-7490/019p2/hilfe_dyndns

Could you please edit your text and put a backslash in front of every opening angle bracket. Otherwise the website interprets the word behind the bracket as a HTML tag and makes it disappear. You can see the result in the preview on the right side. That would make your question better readable.

As for your question: The Fritzbox doesn’t need to find out your Synology’s IPv6 address. The DDNS server will see it, especially the prefix, when the Fritzbox sends its update request, and will publish it in your records. Only the prefix changes from time to time. The second part of the IPv6 address of each device remains constant. You must create a record manually for each device so they get their individual IPv6 addresses. One single device can appear with different hostnames but only one IP address. This can be useful if you run different services on one device.

Ah, and one more hint: Don’t give your Synology a name containing “cloud” - these records got lost quite often in the past and had to be recreated every time.

1 Like

Thank you, Thomas for the reply!
Your hints and advices are always very helpful and informative!

  • I am not able to edit my previous posts?
    If this is configurable somewhere in my profile settings, I will be grateful if you help me to configure this?
  • …putting backslash in front of every opening angle brackets…
    Do you mean like this:
    [https]://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv6prefix=<ip6lanprefix>]
  • Which record do you mean, when you say: “You must create a record manually for each device so they get their individual IPv6 addresses”
    Do you mean the record in device configuration menu, the Fritzbox record or the Dynv6 Record?
  • Can you give me an example of: “One single device can appear with different hostnames but only one IP address. This can be useful if you run different services on one device.”
    On my Synology NAS I have a WEB Server and a simple HTTP site. This site is registered on dynv6dotcom and the requests to its DNS Name over IPv6 are configured on my Fritzbox to be forwarded to the Synology device. What other service may I configure on the Synology NAS and is the NAS device accessible form Internet without forwarding respective ports on the Fritzbox?
  • regarding Synology name to not contain “cloud”: which name do you mean, the local network name, the WEB site name 47906dotdynv6dotnet or any other name?

Hi 47906,

  • editing: I didn’t need to configure anything for this. You should see a pencil icon below your posts, just click on it.

  • backslashes: Yes, that looks good. I didn’t write about square brackets " [ ] ", though. They are definitely not needed here.

  • records: Click on My Zones, → your zone name (47906.dynv6.net ) → Records. You will see a list of your (perhaps only one) web addresses. An IPv6 record is of type AAAA. Chose your record and click on edit. If there is none, click on Add record. You will see two fields: “Name”, which should contain the bare host name (e.g. 47906). The “Data” field shall contain the host part of your Synology’s IPv6 address (e.g. ::dead:beef:dead:5eed).
    To edit the zone part of your IP addresses manually (e.g. 2003:f8:ff45:a1b2::), go to My Zones → your zone → Edit zone. But this part is usually done by the update script.

  • different services: If you have just one HTTP server running, then you are already fine if you just open the ports 80 (http) and/or (better) 443 (https) on your Fritzbox and forward requests on those ports to your NAS. But If you want to reach your NAS via sftp or ssh, you would need to run these services on the Synology, too. In this case your could give them different names (e.g. ssh.47906.dynv6.net), but the IP address would remain the same, of course.

  • cloud: I mean the website name.

I’m going to travel for several weeks, and I’m afraid there will be poor network out there, so maybe I won’t be able the answer you further questions immediately.

Thank you Thomas for your prompt responses!
Now, after your last reply I can see a pencil under all my responses.
Before it was not there, there was only bookmark, like and delete message :slight_smile:
However, the pencil is now there, so I can edit my future responses.
The square brackets was put by me, because the forum did not allowed me to publish an reply with a web site link inside - it was wondering for me, but however, after putting square brackets around the http it was possible to reply :slight_smile:
The record for 47906.dynv6dotnet is already configured and is working perfectly with the assigned IPv6 address.

Please tell me since when you are back from your travel, so I can ask further questions?
Generally it is only 1 actual question:

  • is the Synology NAS with its IPv6 address accessed directly from Internet or it is still behind the firewall of the Fritzbox router, so I need to forward the IPv6 requests for Synology from the Fritzbox

However I guess, I can test this by stop forwarding on the Fritzbox router the IPv6 requests from Internet to Synology, right?

Hi,
I’m glad it’s working for you!
The NAS is still behind the Fritzbox, so port forwarding inside the Fritzbox is needed. However it has its own IPv6 address which is different from the Fritzbox’s one. (This is different from IPv4, where the external public address is the same for all devices and each open port is forwarded to a dedicated local address (e.g. 192.168.178.10) via NAT (Network address translation). )
BTW, it is possible to quote Web addresses here. Just click the warning away (the little X on the right side), or press [Esc].
I’ll be back end of September.

Hi Thomas, it is almost End of September and I hope you are back online.
Unfortunately the script located on my Fritzbox for updating the Synology WEB Server behind the Fritzbox is not working again :frowning:.
Following command is in the Update-URL field of the Fritzbox DynDNS Section:

https://dynv6.com/api/update?hostname=&token=&ipv6prefix=

The actual IPv6 of Synology WEB Server is: 2003:dd:e71b:7c00:211:32ff:fe64:3fdc
The actual IPv6 of Fritzbox is: IPv6-Adresse: 2003:dd:e7ff:1b9d:eadf:70ff:fee0:9710
IPv6-Präfix: 2003:dd:e71b:7c00::/56

Please help me to resolve this problem!

Best wishes,
Latchezar

May I try to help you?

I asume that you fill the right values in the fields of the Fritzbox DynDNS Section.

Update-URL (exactly this string, no substitutions)

https://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv6prefix=<ip6lanprefix>

Domainname
your dynv6 domain

Benutzername
your HTTP Token

With correct values, after a reconnect, the page “Übersicht” under the item “DynDNS” should show the following:

aktiviert, [your dynv6 domain], IPv4-Status: erfolgreich angemeldet, IPv6-Status: erfolgreich angemeldet

Can you confirm that, please?

Thank you, Sam for your reply!

There was an error in my configuration:
Benutzername was my email address, which is wrong.
I have replaced the email address with my HTTP Token fron the Dynv6.com web site
I have also replaced the login password with the “none” string, as described in the installation instructions on the dynv6 web site:
47906.dynv6.net · Instructions

IS this correct or do I have to put my Dynv6.com login password on this place?

Unfortunately even after reconnect, the page “Übersicht” shows the same results:

[DynDNS]: aktiviert, 47906.dynv6.net, IPv4-Status: Fehler, IPv6-Status: unbekannt

Thank you in advance for your response!

The script is still not working.
This is the actual configuration:
image

And this is the IPv6 configuration of the Synology NAS:
image

Hi Latchezar,
yes, I’m back now :slight_smile:

From what I can see from here, your IPv6 record is outdated, and there is no IPv4 record at all.

Unfortunately the instructions for FritzOS on the Dynv6 page are not quite correct.
For the update URL, you should follow Sam’s suggestion. It should work for IPv6.
If you want records for both IPv4 and IPv6, the correct URL string would be
https://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv4=<ipaddr> https://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv6prefix=<ip6lanprefix>
(all in one line separated by a white space)
For “Domainname” and “Benutzername” copy the corresponding entries from the Dynv6 instruction page. The Fritzbox will replace the placeholders in the URL strings with these contents when sending its update request to Dynv6.
The password is not used here.

Next, please adjust the Prefix length in your Synology IPv6 configuration. It should reflect the prefix length assigned by your provider, in your case 56, not 64.
(Here you tell the device how many bits of the address are the same for all of your devices behind the Fritzbox - this is the prefix and will be changed on each reconnect. The rest of the address remains constant and is permanently assigned to a specific device.)

If you want to test the update afterwards, you can just enter ping 47906.dynv6.net on the command prompt. If available on your computer, dig @ns1.dynv6.com 47906.dynv6.net A and dig @ns1.dynv6.com 47906.dynv6.net AAAA would give more information.

Hope this helps!

Thank you Thomas, welcome back!

I followed the instructions of Sam and replaced the Benutzername with the token from Dynv6.com for my zone.
However the Fritzbox does not allow to save the configuration without a password.

What should I put in the Password field: my password for login to dynv6.com or the text “none” as shown in the dynv6.com instruction page?

Thank you in advance for your response!

…just for the documentation: as I did not find a dig command in Windows 10, I used the online dig checker for my web site:

Unfortunately the response was negativ, as the saved in dynv6.com web site IP v6 address is old and is not updated by DynDNS function of the Fritzbox.

I have tried both for password field: the actual password for logging into dynv6.com and string “none”.
No success!
Even after reconnection the fritzbox to the telekom provider, the result for IP v6 is still “unbekannt”:

DynDNS aktiviert, 47906.dynv6.net, IPv4-Status: Fehler, IPv6-Status: unbekannt

You’re welcome :slightly_smiling_face:
So I’d suggest the following:

You should get a nearly blank page just saying “addresses unchanged” (or “addresses updated”). This would mean that the IPv4 part works.

Next, find out the IPv6 prefix (in your case, it should look like 2003:dd:e7XX:XX00 where XX:XX changes on reconnect) and replace YOURIP6PREFIX below with the actual prefix, including the two trailing colons.
https://dynv6.com/api/update?hostname=47906.dynv6.net&token=YOURTOKEN&ipv6prefix=YOURIP6PREFIX

The result should be the same as for IPv4.

These are the update URLs the Fritzbox usually generates itself and sends them to Dynv6 on address update.

If the addresses are “unchanged”, then the Fritzbox has already done its job, and the issue is somewhere else. If not, then there is something wrong with the DynDNS settings in the Fritzbox.

If it looks fine so far, please verify you have created an AAAA record. If you leave the “Name” field empty, your device will be reachable directly as 47906.dyndns.net. The “Data” field must contain the device specific part of the IPv6 address, in your case it is ::211:32ff:fe64:3fdc (note the leading colons).

For IPv4 this step isn’t necessary, as all devices get the same external IPv4 address.

Again you can try out the result with the online dig checker. If you specify the resolver as ns1.dyndns.com (or ns2 or ns3 if ns1 doesn’t do) you need not wait until your DNS entries are propagated.

At last you need to set port forwarding (Portfreigabe) in your Fritzbox for your Synology NAS, probably on port 80.
I’d like to mention that any open port is a potential security leak. There are thousands of automated port scanners out there who will find it and try to intrude.

Thank you Thomas for the quick response!

As you probably remember, you helped me in the past to configure the dyndns script in Fritzbox correctly and it has worked for a couple of weeks/months.

I just checked the record by dynv6.com:

Type Name Data
AAAA 47906.dynv6.net 2003:dd:e71c:800:211:32ff:fe64:3fdc

The address is now wrong because this is the old IPv6 address of the synology.
The problem at this time was that we configured the record without the ability to check it as there is no procedure for this and as I am not experienced in IPv6 configuration and do not know how to manually change the IPv6 address of the synology.

However, now I am not updating the record in Dynv6.com for a purpose, because I an not sure when and how the IPv6 address of my Synology changes and how and when the dyndns script in Fritzbox is automatically renewed.

However, I have now changed the Update- URL field in Fritzbox to:

https://dynv6.com/api/update?hostname=&token=&ipv6prefix=<2003:dd:e71c:c300::
as this is the IPv6 prefix in the Fritzbox:

IPv6-Adresse: 2003:dd:e7ff:1f66:eadf:70ff:fee0:9710, Gültigkeit: 14399/1799s,
IPv6-Präfix: 2003:dd:e71f:4600::/56, Gültigkeit: 14399/1799s

Unfortunately the same result after reconnect: IPv6-Status: unbekannt

Any further ideas?

Hello Latchezar,

I’m afraid you didn’t get me correctly: It’s not a good idea to configure the IPv6 prefix as a static string in the Fritzbox. It must be <ip6lanprefix> as it was before. The prefix is assigned by Telekom and changes on every reconnect. The Fritzbox determines its current value and sends it to Dynv6 in order to update the record(s). In other words, this part of the update URL is composed by the Fritzbox dynamically when it sends it to Dynv6.
What I’ve been asking you for was to compose this URL manually and send it to Dynv6 just with your browser in order to see what happens. You just do manually what normally the Fritzbox does automatically each time it gets a new address.

What do you see if you click on “edit” on the Dynv6 records page? As I mentioned above, the “Name” field should be empty (it seems to be), and in “Data” you should see just ::211:32ff:fe64:3fdc, not the complete address. This part of the address (the host part) is constant and never changes. The complete address will then be composed of the prefix and the host part. It changes automatically when the prefix changes.
You can check the prefix used by DynDNS on its Status page. What do you see? - It must be the same as in the Fritzbox, otherwise it is outdated and must be updated.

I am asking you those questions as I want to find out whether the issue is in the Fritzbox or in the Dynv6 configuration.

BTW: You can also check the Fritzbox’s system log: System/Ereignisse - perhaps it can give us an additional hint was goes wrong with the dyndns update.

Sorry Thomas, I am not very concentrated today!

So, now after putting the string in question in a browser I see following result:
addresses updated

This is a good step ahead :slight_smile: Thank you!
So, now the record in Dynv6 is actualized and working and now I have the old problem, that I am not able to change the Ipv6 address of my Synology, because I don’t know how and what to change.

The “edit” screen in dynv6.com shows the right prefix (I guess) because it was just updated manually by me over the internet browser. However there is a difference from the previous record, as now there is only the IPv6 prefix part:

Thank you very much for helping me so far.
Could you please help me further to change the actual IPv6 address of the synology and then to check if the DynDNS script in the Fritzbox configuration is working properly?

P.S.:

image

This is a ping command from windows command prompt of a desktop inside my local network.
it looks like the IPv6 address is correct but the DNS relations is not updated, which is to be expected, as I can see in the Dynv6.com record for my zone:

image

Just a stupid suggestion from me:
The menu of the fritzbox is displayed in german and instead of “hostname” there is “Domainname” and instead of “user” there is “Benutzer” displayed.
Could it be, that the script is not finding the right names from which to read the variables, because by manually executing the Update-URL from web browser window it works and the IPv6 prefix in the edit window is updated. Hoever, even with updated record in Dynv6.com, I am not able to ping or trace the synology web site by IPv6 address.