DYNV6 deleting records

Hello,

I have few subdomains that point to AAAA record (Mac adress of a device in local network), but every now and then they get deleted somehow. Anyone knows a reason why my subdomains get deleted? Thanks

4 Likes

I have the same problem, but with one specific A record… It gets deleted randomly.

1 Like

Same for me with a CNAME. Is there a way to set the CNAME via rest-API?

Does your CNAME point to a domain which points to A record or AAAA record? Anyways, I had to change provider, nothing worked out for me except manualy updating records as soon as they got deleted, which is definitely not the solution.

Yes, it points to a domain which points to A record. And I am also updating manually whenever it changes. I have a script monitoring my records, now looking for an easy way to correct it automatically…

You can use cloudflare if you need to point it just to CNAME. (or any domain registar)

Was coming here to add my plus one.

Since my situation sounds very alike:
A zone “NAME.dynv6.net” with normally 7 A-Records each pointing to the same fixed IPv4.
These records never get updated once created.
Now since beginning of March (at least when i noticed) one of the records is gone.
Recreated and gone again under a day (don’t know for sure).

Looking through the other threads, the next big one “AAAA record got lost” is actually the same problem it seems.

Last post from @dmke AAAA record got lost seems to be relating to this confirmed bug [solved] AAAA RRs for zones can't be resolved,
but it looks very much like this bug is not yet fixed.
The following posts could help you to apply a workaround, until someone can look into it i guess.

I must admit it is a while since end of November, but also it is a free service (which i appreciate).

So just wanted to point over to the other thread to keep it in one place?

edit: typo grammar

Some of my Records also magically disappear within a few hours or tens of minutes.
Whether it is a CNAME or A record, it will be lost.

These disappearing-records have existed normally for a few months. However, the newly added test record does not seem to disappear.

I have located the time of this disappearance from the log file my record recheck script in my server, that is, it started on nearly 8 am of March 4th 2021 (UTC).

I hope this information is useful to the community.

Same issue. Two TXT records needed for ProtonMail domain verification just disappeared a couple of days ago.

See the thread about AAAA records getting lost. My TXT record for google site verification keeps getting booted on a regular basis as well.

Hey there!
Got the same issue since a couple of weeks. In my case i got a few A and AAAA records. At some point a few records disappeared but i can’t really remember which. Since that point one A and an identical named AAAA record just dissapear. In my experience it is not a problem to use one hostname for one A and AAAA host.
However i never really had any issues with this dynv6.com! Thanks for the years of good and reliable Service.
Would be nice if it continues this way :wink:

Hi,
for me it sems like it is removing specific names.
I have one CNAME which is cloud. This is always removed after some minutes.
All other CNAMEs have no problems.

Same for me, I am also using “cloud” as CNAME. And things getting worse: Last week I’ve written a small script which recreates the records if its missing. It worked very nice for a few days, but since yesterday I get permission errors and the trouble starts again.

I always loose my nextcloud A record.
So +1 for cloud

It’s “cloud” for me as well. See also AAAA record got lost, as mentioned by @tncom.
As for your permission issue:
I have a script that does basically the same as yours, but uses ‘dig @nsX.dynv6.com’ (X={1,2,3}) in order to check for the records. So it needs to login via the REST API only if a record got actually lost. This works for me so far.
For script examples check the above link.
Thomas

And… my TXT record got hosed again.

i also have the same problem. My subdomain is named cloud and i also point to a nextcloud installation. I have set some other records as well.

A-Record to cloud.blabla.tld ← disapears automatically
A-Record to docsrv.blabla.tld
A-Record to blabla.tld ← disapears automatically
same for ipv6:
AAAA-Record to cloud.blabla.tld
AAAA-Record to docsrv.blabla.tld
AAAA-Record to blabla.tld

I can’t say, how often the A-records get lost. It’s a testing domain only. But every morning, i try to connect, the cloud record is disapeared.
My update client is a AVM Fritz Box 6591 Cable. It’s a 500/50 dual stack account.
The router reports a successfully login for IPv4 and IPv6.

I really appreciate any help on this issue.

1 Like

I’m having a similar problem. My MX records keep being deleted.

It looks like I ran into this problem today… 3 times already.

I have a homeserver that runs Traefik and thus can create multiple sub-domains. So instead of having to update each and every one of them I added a wildcard-CNAME for my domain that points to the AAAA-Record.

However today I noticed none of my subdomains work. After a bit of checking I found that the CNAME was missing. I added it (at around 11:00 CET), checked again 5 minutes later and it was gone . After I added it again it appeared to stick, but I just checked again (13:30 CET) and it’s gone again.

Anyone knows why this happens and how to prevent it? It’s rather annoying as I just switched to this service like a week ago and everything worked fine until today.

I’ve just noticed that MX records seem to have been deleted for all of my domains, and for domains owned by friends who are also using dynv6.com

Has anyone else found that their MX records aren’t working any more?